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ВВЕДЕНИЕ 
 
Программирование на языке С++ сейчас вышло на новые 

рубежи, которые определяются индустриальными регламента-
ми. Это новое направление основывается на объектно-ориенти-
рованной методологии и связано с использованием унифициро-
ванного языка UML (Unified Modeling Language). Современные 
методы программирования через абстрактные образы унифици-
рованного языка позволяют получить до готового 70 % кода. 
Однако остается задача — доработать, встроить алгоритмы, 
протестировать программу, внести некоторые изменения в про-
грамму. Поэтому, так или иначе, знание основ языка является 
необходимым условием для полноценной работы программиста. 

В данном пособии представлено два способа выполнения 
лабораторных работ. Один способ связан с применением компи-
лятора среды Visual C++, а второй основан на применении 
встроенного в электронный учебник компилятора С++. Оба 
компилятора полностью соответствуют всем требованиям стан-
дарта ANSI. Конечно же, первый компилятор более мощный и 
является до настоящего времени средством разработки многочис-
ленных профессиональных приложений. Второй является более 
учебным, способным простить многие погрешности набора начи-
нающего программиста. Между этими компиляторами есть раз-
ница, которая ощутима только опытными пользователями.  

Предлагаем пройти этот путь самостоятельно, начиная от 
встроенного компилятора электронного учебника до профес-
сионального компилятора VC++.  
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1 ИЗУЧЕНИЕ СРЕДЫ РАЗРАБОТКИ VISUAL C++ 

 
Создание приложений для работы в операционной среде 

Windows на языке Visual C++ включает следующие этапы: 
• Написание текстов программ. 
• Создание файлов ресурсов для описания диалоговых 

окон, меню, панелей инструментов, значков и т.п. — элементов 
управления работой программы. 

• Разработка системы помощи для работы с программой. 
• Компилирование исходных текстов программ. 
• Компоновка программы их компонентов. 
• Отладка и модификация программ. 
 
 
1.1 Пользовательский интерфейс  
 
Рабочая область среды Visual C++ 6.0 разделена на две час-

ти: окно рабочей области и окно редактирования.  
Для графического отображения объектов рабочей области 

используется список с древовидным отображением, корневыми 
узлами которого являются проекты. Содержимое этих проектов 
можно представить тремя способами, каждому из которых соот-
ветствует вкладка в нижней левой части рабочей области: 

• ClassView — представляет программу в объектно-
ориентированном виде, отображая классы С++, их методы и 
члены-данные. Двойной щелчок такого объекта вызовет переход 
к его объявлению или реализации; 

•  ResourseView — отображает ресурсы, сгруппированные 
по категориям. Двойной щелчок объекта загружает соответст-
вующий редактор; 

• FileView — показывает все файлы проекта, которые 
можно редактировать. 
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Если щелкнуть объект правой кнопкой мыши, появится 
контекстное меню, пункты которого связаны с этим объектом. 

Для работы с файлами в редакторах программ и ресурсов 
используется окно редактирования. Если Вам не хватает в нем 
пространства, выберите из меню View опцию FullView. 

 
1.2 Меню и панели инструментов 
 
Среда разработки Visual C++ обладает набором меню, по-

зволяющим управлять файлами и рабочими областями проектов, 
настраивать саму среду, а также обращаться к справочной сис-
теме, программе управления исходным кодом и внешним инст-
рументальным средствам. Почти каждому меню соответствует 
панель инструментов, в которой команду можно выбрать одним 
щелчком кнопки мыши. Панели инструментов допустимо на-
страивать — добавлять и удалять кнопки, скрывать и отобра-
жать сами панели инструментов. Поэтому Вы можете сконфигу-
рировать среду по своему вкусу, упростив доступ к часто ис-
пользуемым вами пунктам меню.  

По умолчанию в окне среды Visual C++ отображены три 
панели инструментов. Панель Standart (содержит команды, 
часто используемые при работе с файлами), Build (команды, 
необходимые для сборки и запуска приложений) и WizardBar 
(представляет инструменты для работы с классами).  

При щелчке правой кнопкой мыши на поле расположения 
меню (например, в пустой правой верхней части окна) появится 
полный список возможных панелей, позволяющий скрывать или 
отображать их. 

Показанное ниже упражнение позволит Вам получить опыт 
в настройке пользовательского интерфейса. 

Задача: добавление кнопки в панель инструментов: 
1. В меню Tools выберите пункт Customize. Появится диа-

логовое окно Customize. 
2. Перейдите на вкладку Commands. 
3. В списке Category выберите пункт View. 
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4. Щелкните значок Full Screen (третий слева в первом ря-
ду). Обратите внимание на описание команды, которое появля-
ется под раскрывшимся списком Category. 

5. Перетащите значок Full Screen на панель инструментов 
Standart. 

6. Закройте окно Customize. 
7. Откройте файл с исходным кодом программы, дважды 

щелкнув его в окне FullView. 
8. Испытайте новую кнопку — щелкните ее, чтобы перейти 

в полноэкранный режим. Чтобы вернуться к традиционному 
виду, необходимо снова щелкнуть эту кнопку. 

 
Чтобы удалить кнопку с панели инструментов, достаточно 

щелкнуть ее правой кнопкой мыши и выбрать из контекстного 
меню пункт Delete. 

Помимо жестко установленных на панели кнопок, можно 
определять так называемые «быстрые» клавиши. Рассмотрим 
алгоритм установки такого объекта. 

1. В меню Tools выберите пункт Customize. Появится диа-
логовое окно Customize. 

2. Щелкните вкладку Keyboard. 
3. В раскрывшемся списке Category выберите опцию View. 
4. В списке Commands укажите ToggleFullScreen.  
5. Щелкните после ввода Press new shortcut key, после че-

го нажмите на клавишу PAUSE. 
6. Щелкните кнопку Assign.  
7. Закройте диалоговое окно Customize. 
8. Нажмите клавишу PAUSE. При этом окно редактирова-

ния должно переключаться из оконного в полноэкранный режим 
и обратно. 

 
Рассмотрим некоторые, самые часто используемые, коман-

ды меню. Подменю File служит для работы с проектом в целом, 
а также с его файлами.  

Команда File ⇒ New вызывает диалоговое окно для созда-
ния нового файла (подопция Files), проекта (подопция Projects), 
рабочего пространства (подопция Workspaces) или других доку-
ментов (подопция Other Documents). 
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Команда File ⇒ Open позволяет открыть существующий на 
жестком диске (или дискете, или СД) файл. 

Команда File ⇒ Close закрывает файл, имеющий фокус 
ввода (расположение курсора мыши). 

Команда File ⇒ Open Workspaces открывает существующий 
файл с описанием рабочей области. 

Команда File ⇒ Save Workspaces запоминает изменения в 
рабочей области. 

Команда File ⇒ Close Workspaces вызывает закрытие рабо-
чей области с одновременным сохранением изменений. 

Команда File ⇒ Save (Save as, Save All) позволяет сохра-
нить файл, сохранить файл с новым именем или сохранить не-
сколько файлов одновременно. 

Команда File ⇒ Page Setup выводит диалоговое окно для 
установки размеров верхнего и нижнего колонтитулов и полей 
страницы. 

Команда File ⇒ Print позволяет из соответствующего диа-
логового окна распечатывать указанный диапазон страниц. 

Команда File ⇒ Recent Files (Recent Workspaces) выводит 
список файлов и рабочих областей, которые использовались 
последними, для их быстрого открытия. 

Команда File ⇒ Exit завершает работу с Visual C++. 
 
Подменю Edit служит для редактирования текстов, поиска и 

замены, задания закладок и точек остановки для отладки про-
граммы. 

Команда Edit ⇒ Undo отменяет операцию, выполненную 
последней. Повторное нажатие вызывает отмену предыдущей 
операции. 

Команда Edit ⇒ Redo восстанавливает последнюю опера-
цию. 

Команда Edit ⇒ Cut переносит выделенный участок файла в 
буфер обмена с удалением выделенного из самого текста файла. 

Команда Edit ⇒ Copy копирует выделенный участок файла 
в буфер без его удаления из текста. 

Команда Edit ⇒ Paste копирует содержимое буфера в то ме-
сто файла, где установлен курсор. 
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Команда Edit ⇒ Delete удаляет выделенный участок без ко-
пирования в буфер. 

Команда Edit ⇒ Select all выделяет весь файл. 
Команда Edit ⇒ Find (Find in Files) открывает диалоговое 

окно, в котором необходимо указывать, какой текст следует 
искать и в каком направлении (от начала к концу файла или 
наоборот). 

Команда Edit ⇒ Replace производит замену одних выраже-
ний другими. 

Команда Edit ⇒ Go To позволяет перейти к адресу, полу-
ченному при выполнении отладки, к закладке, к строке с задан-
ным номером, к следующей ошибке, найденной при компиля-
ции программы. 

Команда Edit ⇒ Bookmarks устанавливает именованные за-
кладки для быстрого перемещения по тексту программы. 

Команда Edit ⇒ Advanced активизирует меню третьего 
уровня со следующими командами: 

• Increment Search — производит поиск по мере набора 
текста для поиска, 

• Format — устанавливает отступы в выделенном участке 
текста, 

• Tabify Selection (Untabify) — преобразует символы табу-
ляции в пробелы и обратно, 

• Make Selection Uppercase (Lowercase) — переводит вы-
бранные символы табуляции в пробелы и обратно, 

• Whitespace — вставляет символы-заполнители для зна-
ков табуляции и пробелов. 

Команда Edit ⇒ Breakpoints позволяет установить точки ос-
танова для выполнения отладки программы. 

Команда Edit ⇒ List Members позволяет вывести полный 
список членов класса или структуры после набора оператора 
доступа к его члену. 

Команда Edit ⇒ Type Info выводит описание любого иден-
тификатора программы, на котором находится курсор. 

Команда Edit ⇒ Parameter Info выводит описание аргумен-
тов функции при наборе ее имени и открывающейся скобки. 
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Команда Edit ⇒ Complete Word позволяет автоматически 
завершить набор слова, если в списке доступных слов имеется 
единственное слово, имеющее начало, которое уже подобрано. 

 
1.3 Настройка параметров среды 
 
Выбрав в меню Tools пункт Options, можно вызвать диало-

говое окно Options. В этом окне настраиваются параметры Ва-
шей рабочей среды, от которых зависят вид и возможности 
встроенных в нее инструментальных средств. Данные парамет-
ры применяются ко всем проектам и их конфигурациям. 

В диалоговом окне можно настроить: 
1) редактор кода — начиная с параметров окна и сохране-

ния и заканчивая параметрами таких функций, как автозаполне-
ние кода и цветовое выделение синтаксических элементов. 
Можно эмулировать некоторые версии редакторов; 

2) отображение информации отладчиком; 
3) параметры встроенной программы управления исходным 

кодом; 
4) пути к исполняемым файлам, файлам с исходным кодом, 

включаемым файлам и библиотекам. 
 
1.4 Система помощи приложения 
 
Visual Studio 6.0 поставляется вместе с библиотекой MSDN 

(Microsoft Developer Network). Это справочник разработчика, 
содержащий более 1 Гб технической информации по всем сто-
ронам программирования (включены: документация, техниче-
ские статьи, образцы кода и много другой информации о про-
граммировании на продуктах фирмы Microsoft). 

Библиотека MSDN запускается в собственной среде, осно-
ванной на HTML и снабженной быстрой поисковой системой. 
Несмотря на внешнюю изолированность, программа MSDN 
интегрирована в среду разработки Visual C++. 

В Windows существуют три типа сообщений, посылаемых в 
тот момент, когда пользователь обращается к справочной сис-
теме: 
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1. WM_COMMAND; 
2. WM_HELP; 
3. WM_CONTEXTMENU. 
 
Когда пользователь выбирает в меню команду Help, систе-

ма посылает сообщение WM_COMMAND. Для отображения 
соответствующей справки Вы должны перехватить это сообще-
ние и вызывать систему WinHelp. 

Когда пользователь щелкает правой кнопкой мыши на           
некотором элементе программы, посылается сообщение 
WM_CONTEXTMENU. Надо перехватить это сообщение и вы-
вести его в данном месте контекстного меню.  

Когда пользователь обращается к справочной службе лю-
бым другим способом (например, используя горячую кнопку 
F1), большая часть работы выполняется специально встроенным 
обработчиком событий. В данном случае перехватывается со-
общение WM_HELP.  

При использовании интерактивной справочной системы ис-
пользуется большое количество различных файлов. Конечным 
продуктом является файл, имеющий расширение *.hlp. Он соз-
дается на основе нескольких файлов. В приведенной ниже таб-
лице слово Name следует заменить на имя *.ехе файла приложе-
ния. Известны следующие расширения файлов, служащих для 
разработки компонент справочной системы: 

 
Таблица 1 — Расширения файлов справочной системы 
  
*.h Файлы заголовков содержат определения 

идентификаторов ресурсов и идентификато-
ры тем справок, которые будут использо-
ваться в программе 

*.hm Файлы адресации справок содержат иден-
тификаторы тем справки. Этот файл генери-
руется всякий раз, когда компилируется 
приложение (не рекомендуется вносить в 
него изменения) 

*.rtf Файлы расширенного текстового формата 
содержат тексты справок по каждой теме 



 12

  
Name.cnt Файл таблицы содержания вкладки Contents 

(Содержание) в диалоговом окне Help Top-
ics. Этот файл оглавления поставляется вме-
сте с приложением в дополнение к файлу 
*.hlp 

Name.hpj Файл проекта справочной системы объеди-
няет файлы *.hm и *.rtf, совместно исполь-
зуемые при компиляции файла *.hlp 

 
1.5 Параметры конфигурации проекта 
 
При работе над проектом в некоторых случаях возникает 

необходимость изменения параметров конфигурации проекта. 
Для этого вызовите окно Project Settings, выбрав в меню Pro-
ject пункт Settings. В этом окне можно настроить параметры 
проекта, в том числе и параметры компиляторов и компоновщи-
ка Visual C++. 

Важно отметить, что изменения параметров на любой 
вкладке влияют только на текущий проект и версию сборки, 
указанные в раскрывающемся списке Settings For. Для каждого 
типа сборки можно задать свой набор параметров. Если требу-
ется установить одинаковые параметры для всех версий сборки, 
в списке Settings For щелкните All Configurations. 

Не менее важно при настройке проекта проверить, какую 
его конфигурацию Вы изменяете. 

Приведем описание содержания некоторых вкладок диало-
гового окна Project Settings. 

• General Settings — Здесь можно проводить изменения 
установок компоновки программы, например, исследовать или 
нет в программе статические библиотеки MFC или нет и др. 
Также можно задать каталоги, в которые будут помещаться ко-
нечные файлы. 

• Debug Settings — Здесь находятся параметры, переда-
ваемые программе при ее запуске в отладчике. Кроме того, 
можно использовать переадресацию ввода/вывода, аналогичную 
применяемой в командной строке. 

Продолжение табл. 1 
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• C/C++ Settings — Здесь Вы определяете параметры ком-
пилятора, функциональные возможности языка, соглашения о 
вызове, параметры, связанные с типом процессора, оптимизации 
кода, константами препроцессора и т.п. 

• Linker Settings — На этой вкладке выбирают дополни-
тельные библиотеки, которые следует скомпилировать вместе с 
Вашей программой. 

 
1.6 Типы мастеров проектов 
 
В среде Visual C++ можно строить различные типы проек-

тов. Такие проекты после их создания можно компилировать и 
запускать на исполнение. Фирма Microsoft разработала специ-
альный инструментарий, облегчающий и ускоряющий создание 
проектов в среде Visual C++. 

Рассмотрим некоторые типы проектов, которые можно соз-
давать при помощи различных средств (мастеров проектов) 
Microsoft Visual C++: 

MFC AppWizard (exe) — при помощи этого мастера прило-
жений можно разработать проект Windows-приложения, имею-
щего однодокументный, многодокументный или диалоговый 
интерфейс. Однодокументное приложение может предоставлять 
пользователю в любой момент времени работать только с одним 
документом в окне. Многодокументное приложение, напротив, 
может одновременно представлять несколько документов, каж-
дый в собственном окне. Пользовательский интерфейс диалого-
вого приложения представляет собой единственное диалоговое 
окно. 

MFC AppWizard (dll) — этот мастер приложений позволяет 
создать структуру DLL, основанную на MFC. При помощи него 
можно определить характеристики будущей DLL. 

AppWizard ATL COM — это средство позволяет создать 
элемент управления ActiveX или сервер автоматизации, исполь-
зуя новую библиотеку шаблонов ActiveX (ActiveX Template 
Library — ATL). Опции этого мастера дают возможность вы-
брать активный сервер (DLL) или исполняемый внешний сервер 
(exe-файл). 
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Custom AppWizard — при помощи этого средства можно 
создать пользовательские мастера AppWizard. Пользовательский 
мастер может базироваться на стандартных мастерах для при-
ложений MFC или DLL, а также на существующих проектах или 
содержать только определяемые разработчиком шаги. 

DevStudio Add-in Wizard — мастер дополнений позволяет 
создавать дополнения к Visual Studio. Библиотека DLL расши-
рений может поддерживать панели инструментов и реагировать 
на события Visual Studio. 

MFC ActiveX ControlWizard — мастер элементов управле-
ния реализует процесс создания проекта, содержащего один или 
несколько элементов управления ActiveX, основанных на эле-
ментах управления MFC. 

Win32 Application — этот мастер позволяет создать проект 
обычного Window-приложения. Проект создается незаполнен-
ным, файлы с исходным кодом в него следует добавлять вруч-
ную. 

Win32 Console Application — мастер создания проекта кон-
сольного приложения. Консольное приложение — это програм-
ма, которая выполняется из командной cтроки окна DOS или 
Windows и не имеет графического интерфейса (окон). Проект 
консольного приложения создается пустым, предполагая добав-
ление файлов исходного текста в него вручную. 

Win32 Dynamic-Link Library — создание пустого проекта 
динамически подключаемой библиотеки. Установки компилято-
ра и компоновщика будут настроены на создание DLL. Исход-
ные файлы следует добавлять вручную. 

Win32 Static Library — это средство создает пустой проект, 
предназначенный для генерации статической (объектной) биб-
лиотеки. Файлы с исходным кодом в него следует добавлять 
вручную. 
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2 СОЗДАНИЕ ПРОЕКТА VISUAL C++ 
 
Самым распространенным в мире учебным и производст-

венным пакетом программ является продукт фирмы Microsoft — 
Visual Studio 6.0, в состав которого входит среда программиро-
вания Visual С++. Несмотря на то, что в настоящее время уже 
существует новое поколение среды разработки Visual Stu-
dio.NET, VC++ версии 6.0 не потеряло своих возможностей. 

При выполнении лабораторных работ мы будем использо-
вать среду разработки Visual C++ 6.0. А так как эта среда требу-
ет определенных действий для создания программы, кроме на-
писания исходного кода, то мы сейчас их и рассмотрим. 

 
2.1 Выбор типа проекта 
 
Итак, для написания программы нам необходимо создать 

проект (рабочее пространство). Для этого необходимо запустить 
Microsoft Visual C++ 6.0. После чего выполняем команду:File — 
New или нажимаем сочетание клавиш Ctrl+N. Когда Вы выпол-
ните это действие, появится диалоговое окно, такое же, как при-
ведено на рисунке 1. 

 
Рис. 1 — Диалоговое окно выбора типа проекта 
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В этом окне выбираем тип проекта Win32 Consol Applica-
tion, так как пока будем работать с консольным проектом. В 
поле Project name вводим название нашего проекта, в нашем 
случае это MyProject. Теперь нажимаем кнопку Ok. После этого 
появятся еще два диалоговых окна. В первом ничего не меняем, 
а просто нажимаем кнопку Finish, т.е. создадим пустой проект. 
Пример второго возникающего при выборе проекта окна распо-
ложен на рисунке 2. 

 

 
 

Рис. 2 — Второе диалоговое окно выбора проекта 
 

Во втором диалоговом окне нажимаем Ok. После выполне-
ния команды Finish, появляется третье окно, которое показано 
на рисунке 3. 

Вот и все, наш проект готов, но в нем ничего нет. Теперь нам 
необходимо добавить файлы. Пока ограничимся всего одним фай-
лом. В дальнейшем, когда необходимо будет несколько файлов 
или другие параметры проекта, мы вернемся к теме создания про-
ектов и добавления файлов. А пока выполняем следующие дейст-
вия. Выполнить команду: File — New (или нажать клавиши 
Ctrl+N). После чего появится диалоговое окно, аналогичное 
окну создания проекта. Вид этого окна приведен на рисунке 4. В 
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появившемся диалоговом окне приведено множество типов 
файлов, с которыми может работать VC++, однако для проектов 
C++, как вам известно, необходимо выбрать *.cpp и *.h. 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

Рис. 3 — Третье диалоговое окно выбора проекта 

Рис. 4 — Выбор типа файла для проекта (в нашем случае С++) 
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Здесь выбираем тип файла C++ Source File, в поле File name 
вводим название нашего файла (в данном случае это будет 
main). Нажимаем кнопку Ok. 

Теперь у нас проект готов. Давайте напишем первую про-
грамму. 

Итак, в созданном нами файле пишем следующий код: 
 

#include <iostream.h> 
void main() 
{ 
 cout << "Hello World" << endl; 
} 

 

Разбирать текст программы мы не будем, так как он прост 
(необходимо вывести на экран фразу «"Hello World"»). Мы же 
просто запустим программу. Для этих целей можно отдельно 
производить компиляцию, отдельно компоновку и после этого 
запускать программу, однако все эти действия можно выпол-
нить одновременно. Для этого нажимаем клавиши Ctrl+F5 (есть 
и другие способы выполнения этого действия, но это самое про-
стое, на мой взгляд). Появится окно сообщения, нажимаем Ok в 
этом окне. Если программа написана без синтаксических оши-
бок и Вы выполнили все действия правильно, то программа бу-
дет откомпилирована, скомпонована и запущена на выполнение. 
Вы увидите результат выполнения вашей программы, аналогич-
ный тому, что приведен на рисунке 5. 

 
 

 
 
 
 
 
 
 
 
 
 
 
 Рис. 5 — Результат выполнения первой программы 
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Вот и все, проект готов, написана первая программа. Теперь 
можете переходить к изучению всех остальных примеров. 

 
2.2 Добавление файлов и классов в проект 
 
На данном этапе мы рассмотрим добавление файлов в про-

ект, а так же добавление классов. В среде Visual C++ при добав-
лении классов при помощи встроенного «конструктора» для 
каждого класса создается свой файл. Мы не будем отходить от 
этого и тоже пока будем создавать для каждого класса свой 
файл. Но это не стоит принимать как руководство к действию, 
так как в некоторых случаях это бесполезно или может отрица-
тельно сказаться на всем проекте. Выше уже было сказано, что 
классы в проект можно добавлять посредством конструктора, 
который добавляет много разнообразной информации, на пер-
вых шагах может сильно запутать неопытного программиста. 
Поэтому пока мы будем добавлять классы вручную, но в после-
дующих шагах рассмотрим способ добавления классов посред-
ством конструктора. 

Создадим свой класс, описание которого поместим в файл 
MyClass.h, а его реализацию поместим в файл MyClass.cpp. 

Для выполнения этого откроем наш проект, который мы 
создали в шаге создания проекта. Для открытия проекта нужно 
выполнить следующие действия: запускаем среду Visual C++, в 
меню выбираем "File", а здесь, в свою очередь, выбираем пункт 
"Open Workspace". Обратите внимание, что выбираем этот 
пункт, а не просто функцию "Open", так как пункт "Open" пред-
назначен для открытия других файлов, а не файла проекта. По-
сле того как Вы выполнили вышеописанное действие, появится 
диалоговое окно открытия проекта (см. рис. 6). 

Здесь мы "добираемся" до нашего файла проекта. В данном 
случае — это будет файл MyProject.dsw. Выбираем его и нажи-
маем "Открыть". Стоит отметить, что файлы проектов имеют 
расширение dsw.  

После открытия проекта Вы должны увидеть следующий 
результат (см. рис. 7): 
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Рис. 6  — Диалоговое окно "Open Workspace" 
 
 

 
 

Рис. 7 — Результат открытия проекта. 
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Немного рассмотрим окно среды Visual C++ 6.0. Так, в ле-
вой части экрана Вы можете увидеть менеджер проекта, в кото-
ром имеется несколько закладок (в данном случае 2, но в боль-
шинстве — 3). Первая закладка ClassView. На ней отображаются 
классы, их методы и поля, а так же глобальные функции. Вторая 
закладка, которую мы здесь наблюдаем, — это FileView, на кото-
рой отображаются все файлы нашего проекта (см. рис. 8). 

 

 
 

Рис. 8 — Менеджер проектов  
(открыта опция "FileView") 

 
Проект мы открыли, теперь перейдем к созданию класса. 

Для этого добавим еще два файла к нашему проекту (MyClass.h 
и MyClass.cpp). В этих целях выполним следующие действия. 
Выбираем пункт "New" в меню "File" (или, что, на мой взгляд, 
проще, нажимаем сочетание клавиш Ctrl+N). После этого поя-
вится диалоговое окно, которое было рассмотрено в шаге созда-
ния проекта (там же мы добавляли файл main.cpp немного ра-
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нее). Здесь для добавления файла MyClass.cpp производим те же 
действия, только изменяем имя файла. После того как файл 
*.cpp добавлен, добавим файл MyClass.h. Для этого выполняем 
аналогичные действия с той лишь разницей, что выбираем опцию 
выбора типа файла проекта "C/C++ Header File", а не "C++ Source 
File". 

Теперь подключим наш файл (MyClass.h) к проекту. Для 
этого открываем файл main.cpp (не через Open, а через FileView) 
и в нем дописываем такую строку: #include "MyClass.h". Заметь-
те, что стандартные файлы мы описываем (равнозначно — вы-
зываем) с помощью операторов С++ < >, а созданные пользова-
телем, — через " ". Теперь мы получим такой код в файле main.cpp: 

 

#include <iostream.h> 
#include "MyClass.h" 
void main() 
{ 
 cout << "Hello World" << endl; 
} 

 

Теперь немного преобразуем наш файл main.cpp и напишем 
некоторый текст в остальных файлах. Описывать действия про-
граммы не будем, так как мы здесь рассматриваем работу со 
средой VC++, а не объектное программирование.  

После внесения изменений имеем: 
 

//Файл main.cpp 
#include "MyClass.h" 
void main() 
{ 
 CPrint pr("Hello World"); 
 pr.Show(); 
} 
 
//Файл MyClass.h 
class CPrint 
{ 
char m_str[100]; 
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public: 
 CPrint(const char *pStr); 
 void Show(); 
 ~CPrint(); 
}; 
 
//Файл MyClass.cpp 
#include "MyClass.h" 
#include <string.h> 
#include <iostream.h> 
 
CPrint::CPrint(const char *pStr) 
{ 
 strcpy(m_str, pStr); 
} 
 
CPrint::~CPrint() 
{ 
cout << "Destroy object" << endl; 
} 
 
void CPrint::Show() 
{ 
cout << m_str << endl; 
} 

 

После написания всего исходного текста собираем про-
грамму и запускаем на выполнение (как это делается, мы уже 
рассматривали). 

Если все было сделано правильно и Вы не допустили ни 
одной ошибки при написании исходных текстов, то получите 
результат, показанный на рисунке 9. 

Если же были допущены ошибки, то компилятор выдаст об 
этом сообщение. Как использовать эти сообщения для облегче-
ния поиска ошибок, мы рассмотрим в другом шаге. 
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Рис. 9 — Результат выполнения исправленного проекта 
 

2.3 Создание классов посредством мастера 
 

В этой статье мы рассмотрим создание классов при помощи 
мастера. Для этого мы создадим новый пустой консольный про-
ект с именем WizardProject (как создавать проект, я надеюсь, Вы 
ужу усвоили). После создания нового проекта добавьте в него 
файл main.cpp. 

 

 
 

Рис. 10 — Верхняя часть окна менеджера  
проектов 

 
На рисунке 10 мы видим часть закладки, на которой ото-

бражается наш проект. Для добавления нового класса к проекту 
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необходимо выполнить следующие действия: установить указа-
тель мыши на строку, отображающую название проекта (в на-
шем примере это WizardProject classes), щелкнуть правой кноп-
кой мыши и в появившемся меню выбрать пункт <New Class:>. 
После выполнения этого действия Вы увидите диалоговое окно, 
в котором мы указываем название нового класса. Мастер авто-
матически генерирует названия h и cpp файлов, при желании мы 
можем изменить эти названия. 

На рисунке 11 приведен пример диалогового окна, о кото-
ром говорилось выше. 

 

 
 

Рис. 11 — Окно формирования данных  
о разрабатываемом классе 

 
Здесь в поле <Name> мы вводим название нашего нового 

класса. Для нашего примера создадим класс CStudent. Поля и 
методы этого класса будем добавлять на другом шаге. 

Теперь рассмотрим возможность изменения имен *.h и 
*.cpp файлов. Для изменения имен этих файлов нажмем кнопку 
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<Change:>. После чего появится диалоговое окно, пример кото-
рого приведен на рисунке 12. 

 

 
 

Рис. 12 — Окно изменения имен файлов проекта 
 

2.4 Добавление полей и методов мастером 
 
В этой части мы рассмотрим добавление полей данных и 

методов к нашему проекту, созданному на прошлом шаге, по-
средством мастера. Для этого откроем проект WizardProject.  

Добавим к нашему классу CStudent такие поля данных:  
char m_szName[100] (фамилия),  
int m_nAge (возраст),  
char m_szGroup[100] (группа, в которой обучается студент).  
 
Добавим методы:  
void SetName(const char *pName) (метод, посредством кото-

рого будем задавать фамилию студента),  
void SetAge(int nAge) (метод, посредством которого будем 

задавать возраст студента),  
void SetGroup(const char* pGroup) (метод для задания груп-

пы, в которой обучается студент),  
void Show() (метод для отображения всех установленных 

данных). 
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Рис. 13 — Выбор опции добавления полей данных 

 
Для добавления вышеописанных полей на вкладке Class-

View щелкаем правой кнопкой мыши по классу CStudent и вы-
бираем пункт меню <Add Member Variable:>, как это показано 
на рисунке 13. После выполнения этого действия появится диа-
логовое окно, аналогичное приведенному на рисунке 14. 

 

 
 

Рис. 14 — Окно занесения полей данных 
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Здесь в поле <Variable Type> вводим тип поля, а в поле 
<Variable Name> указываем имя поля (но так как мы имеем дело 
с массивом/строкой, то указываем и размерность массива). В 
этом же окне указываем модификатор доступа (в данном случае 
private) и нажимаем <Ok>. Добавление остальных полей анало-
гично, за исключением поля возраста, там указывать размер-
ность не нужно. 

Практически так же производится добавление методов клас-
са. Немного рассмотрим этот процесс. Для добавления нового 
метода классу производим действия, аналогичные описанным 
выше, за исключением того, что в меню выбираем пункт <Add 
Member Function:>. Появится диалоговое окно, аналогичное окну 
добавления полей класса; пример окна приведен на рисунке 15. 

 

 
 

Рис. 15 — Окно добавления полей класса 
 

Здесь в поле <Function Type:> указываем тип функции, в 
поле <Function Declaration:> объявляем метод, так же здесь мо-
жем указать модификатор доступа и нажимаем Ok. Таким же 
образом добавляем остальные методы класса CStudent. 

Теперь внесем некоторые изменения. После этого файлы 
должны выглядеть следующим образом: 

 
//файл main.cpp 
#include "CStudent.h" 
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void main() 
{ 
 CStudent Student; 
 
 Student.SetName("Ivanov"); 
 
 Student.SetAge(20); 
 
 Student.SetGroup("925-15"); 
 
 Student.Show(); 
} 
 
//файл CStudent.cpp 
// CStudent.cpp: implementation of the CStudent class. 
// 
////////////////////////////////////////////////////////////////////// 
#include "CStudent.h" 
#include <string.h> 
#include <iostream.h> 
////////////////////////////////////////////////////////////////////// 
// Construction/Destruction 
////////////////////////////////////////////////////////////////////// 
CStudent::CStudent() : m_nAge(0) 
{ 
   memset((void*)m_szName, 32, 100); 
   memset((void*)m_szGroup, 32, 100); 
} 
 
CStudent::~CStudent() 
{ 
} 
void CStudent::SetName(const char *pName) 
{ 
   strcpy(m_szName, pName); 
} 
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void CStudent::SetAge(int nAge) 
{ 
   m_nAge = nAge; 
} 
 
void CStudent::SetGroup(const char *pGroup) 
{ 
   strcpy(m_szGroup, pGroup); 
} 
 
void CStudent::Show() 
{ 
cout << "Name:\t" << m_szName << endl 
       << "Age:\t" << m_nAge << endl 
       << "Group:\t" << m_szGroup << endl; 
} 

  

Собираем программу и запускаем на выполнение. Если все 
сделано безошибочно, то Вы увидите такой результат, который 
показан на рисунке16. 

 

 
 

Рис. 16 — Окно результата запуска программы 
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Можно считать, что к настоящему моменту времени, при 
надлежащем выполнении всех вышеописанных возможностей 
построения и запуска проектов VC++, вы готовы к самостоя-
тельному выполнению лабораторных работ. 
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3 КОМПИЛЯТОР ЭЛЕКТРОННОГО УЧЕБНИКА 
ПО С++ 

 
Ранее мы рассмотрели возможность выполнения лабора-

торных работ в профессиональном компиляторе Microsoft Visual 
C++. Однако для обучения основам программирования на С++ 
можно использовать и более простые компиляторы, такой, как, 
например, установлен в электроном учебнике. Работу со встро-
енным компилятором можно начать, запустив электронный 
учебник по ООП (см. рис. 17), выбрав меню Файл/Практика и 
любой из имеющихся примеров. 

 
 

 
 
 
 

Рис. 17 — Выбор примеров на С++ в учебнике по ООП 
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Следующим шагом необходимо щелкнуть правой кнопкой 
мыши над примером и в выпавшем меню выбрать подменю «от-
крыть файл в редакторе» (см. рис. 18).  

 
 

 
 
 

Рис. 18 — Открытие меню с возможностью редактирования примеров 
 

 
В открывшемся окне появится редактор компилятора и 

пример кода (см. рис. 19). Можно выполнить две функции с 
помощью данного компилятора: 1) набрать (или загрузить уже 
готовый файл) и откомпилировать проект или 2) набрать (или 
загрузить уже готовый файл) и откомпилировать и запустить 
созданный исполняемый файл.  
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Рис. 19 — Внешний вид окна редактора и компилятор языка С++ 
 
В редакторе имеются следующие опции (рис. 20).  
 

 
 
 
 
 
 
 
 

Создать 
файл 

Открыть 
файл 

Сохранить 
файл 

Выход 

 
Рис. 20 — Опции редактора 

 

Компилятор имеет следующие функции меню: 
1) Файл: Новый CPP файл, Открыть, Сохранить, Сохранить как. 
2) Правка: Отменить, Повторить, Вырезать, Копировать, 

Вставить. 
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3) Компиляция: Компилировать и выполнить, Компилиро-
вать, Выполнить. 

Выбор опций компилятора показан на рис. 21. 
 

 
 

Рис. 21 — Опции компиляции 
 

На рисунке 22 показан пример компиляции примера, при-
веденного на рисунке 19. Компилятор настроен таким образом, 
чтобы облегчить работу по изучению основ программирования 
на С++. Многие погрешности набора и неточности кода будут 
автоматически скорректированы. При этом все выполненные 
корректирующие действия будут отображены в нижнем окне, 
где показываются результаты компиляции. 

При запросе на компиляцию редактор попросит вас ввести 
имя компилируемого файла.  
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Рис. 22 — Результат компиляции 

 
Рис. 23 — Действия по сохранению файла 
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В электронном учебнике существует еще один способ вы-
зова редактора. В этом случае откроется редактор с пустым до-
кументом, в нем необходимо уже набирать свой программный 
код.  

 

 
Рис. 24 — Открытие редактора из основного меню 

 
Рис. 25 — Пустой редактор 
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Редактор может быть вызван также из основного меню 
учебника, для этого необходимо выполнить действия, показан-
ные на рис. 24. В результате выполнения указанных действий, 
появится редактор, готовый к набору программ, как это показа-
но на рис. 25. После того, как программа набрана и откомпили-
рована, существует возможность сохранения результатов рабо-
ты (см. рис. 26). 

 

 
 

Рис. 26 — Меню открытия и сохранения файлов 
 
Хотелось бы предупредить читателей об одной особенности 

встроенного компилятора. В нем необходимо набирать все фай-
лы проекта вместе (*.cpp и *.h). Это связано с тем, что в компи-
ляторе отсутствует опция подготовки проекта. Однако это об-
стоятельство нисколько не снижает возможности обучения язы-
ку програмирования С++ и не изменяет результаты работы ком-
пилятора. 
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4 ЛАБОРАТОРНЫЕ РАБОТЫ ПО ОБЪЕКТНО-
ОРИЕНТИРОВАННОМУ ПРОГРАММИРОВАНИЮ 

 
4.1 Лабораторная работа № 1 

 
Тема: Классы. Открытые и закрытые уровни доступа. 

Конструкторы. Инициализация данных объекта. Определение 
методов. Создание объекта в памяти. Стандартные потоки 
ввода-вывода. 

 
1.  В среде программирования на С++ создайте консольный 

проект с именем LAB1 в каталоге LAB1. 
2.  В проекте создайте файлы main.h (заголовочный файл) и 

main.cpp (файл исходного кода). 
3.  В файле main.h определите с помощью ключевого слова 

class объект Person. 
 
Данные объекта:  

Номер человека (целый тип) 
ФИО (символьный массив) 
Пол (логический тип: 0-муж., 1-жен.) 
Возраст (вещественный тип) 
 
Пусть данные имеют закрытый уровень доступа (private).  
4.  Опишите конструктор объекта, аргументы которого бу-

дут инициализировать все данные объекта.  
5.  Опишите конструктор объекта по умолчанию (без аргу-

ментов), проинициализировав все данные. 
6.  Опишите в объекте функцию void Print() с открытым 

уровнем доступа (public), которая будет выводить данные на 
экран.  

7.  Откройте файл main.cpp. С помощью директивы 
#include включите в файл main.cpp заголовочные файлы 
<stdlib.h>, <string.h>, <iostream.h>, а также ваш заголовочный 
файл "Main.h". 

8.  Ниже определите конструктор объекта, инициализи-
рующий все данные объекта значениями аргументов. В теле 
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конструктора используйте функцию strcpy(стр1, стр2) для копи-
рования строки имени человека (ФИО). 

9.  Затем определите функцию void Person::Print(). В теле 
функции для вывода данных используйте стандартный поток 
вывода cout << значение1 << значение2 << … << endl; 

10.  Ниже напишите главную функцию программы int 
main(). Внутри ее создайте объект Person, указав все значения 
данных объекта. Выведите данные объекта на экран, вызвав 
функцию Print.  

11.  Затем создайте динамический объект Person с помо-
щью обычного конструктора и оператора new. Выведите данные 
объекта на экран. Удалите динамический объект из памяти с 
помощью оператора delete.  

12.  Напишите функцию ввода данных в объект с клавиату-
ры void Person::Input(). В теле функции для ввода данных ис-
пользуйте стандартный поток ввода cin >> значение1 >> значе-
ние2 >> … ; 

13.  Затем в теле функции main создайте объект Person с 
помощью конструктора по умолчанию и введите данные в объ-
ект с клавиатуры, вызвав функцию Input. Выведите данные объ-
екта на экран.  

 
4.2 Лабораторная работа № 2 

 
Тема: Создание динамического массива объектов. Дест-

руктор объекта. Два типа полиморфизма: принудительное 
приведение типа, перегрузка функций и перегрузка операторов 
(унарных и бинарных). 

 
1.  В среде программирования на С++ создайте консольный 

проект с именем LAB2 в каталоге LAB2. 
2.  Переименуйте файл main.h из предыдущей лабораторной 

в person.h. Создайте файл person.cpp и включите в проект эти 
два файла. Переместите конструктор и функции объекта Person 
из main.cpp в файл person.cpp. Таким образом, файл person.h 
содержит описание объекта Person, а файл person.cpp — реали-
зацию объекта Person.  
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3.  Включите в проект файл main.cpp и очистите тело функ-
ции main(). 

4.  Определите объект Group, который будет содержать ди-
намический массив объектов Person. Создайте два файла group.h 
и group.cpp и включите их в проект. 

5.  В файле group.h определите с помощью ключевого слова 
class объект Group. 

Данные объекта:  
 

размер массива (целый тип) 
указатель на массив (тип Person* ) 
 
Пусть данные имеют закрытый уровень доступа (private). 
6.  Опишите конструктор объекта с одним аргументом — 

размер массива (целый тип) и деструктор объекта. 
7.  Откройте файл group.cpp. С помощью директивы 

#include включите необходимые заголовочные файлы. 
8.  Определите конструктор объекта Group. В теле конст-

руктора проинициализируйте данные объекта, т.е. проинициа-
лизируйте размер массива значением аргумента конструктора и 
выделите динамическую память под массив с помощью строки 
кода:  

 
указатель на массив = new Person[размер массива]. 
 
9.  В деструкторе объекта освободите память, занимаемую 

массивом, с помощью строки кода:  
 
delete [] указатель на массив.  
 
Таким образом, мы создали объект Group, который содер-

жит массив объектов Person.  
10.  Определите открытые (public) методы для объекта 

Group. Напишите функцию void Group::Print(), которая выводит 
в цикле for все записи массива на экран. В теле цикла примените 
ранее написанную функцию Print() для объекта Person. 

11.  Напишите функцию int Group::Size(), которая возвра-
щает размер массива. 
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12.  Напишите функции void PutPerson(int i, Person& man); 
и Person& GetPerson(int i);, первая функция заносит объект man 
типа Person в i-й элемент массива, вторая функция возвращает 
объект типа Person из i-го элемента массива.  

13.  Заполните массив данными и затем выведите их на эк-
ран. Для этого в теле функции int main() сначала определите 
массив имен, которые будут заноситься в поле ФИО объекта 
Person, например:  

 
char names[5][25] = {"A", "B", "C", "D", "E"};.  
Затем создайте объект с именем group типа Group размером 

пять записей, т.е. Group group(5);. 
14.  Ниже с помощью цикла for заполните массив данными. 

Для этого в теле цикла создайте объект Person, проинициализи-
ровав все его данные, и с помощью функции PutPerson занесите 
объект в массив. 

15.  Выведите массив на экран с помощью строки кода: 
group.Print();. Получилось? Если да, то вы научились создавать 
динамический массив объектов, определять функции работы с 
таким массивом и выводить его на экран. 

16.  В этой части лабораторной работы изучим первые два 
типа полиморфизма — это: а) принудительное приведение типа; 
б) перегрузка функций и операторов.  

17.  Напишите функцию приведения типа. Для этого с по-
мощью ключевого слова operator напишите функцию объекта 
Person, которая преобразует тип Person в double. Пусть функция 
возвращает возраст человека, например:  

 
Person::operator double() { return this->Age; }.  
 
Что означает ключевое слово this? 
18.  Проверьте функцию преобразования типа. В функции 

int main() далее определите переменную double и присвойте ей 
объект Person, например: 
  

double age = group.GetPerson(2);.  
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То есть совершается неявное преобразование из типа Person 
в тип double при обращении к объекту. Выведите значение пе-
ременной на экран. 

19.  Перегруженные функции имеют одинаковое название, 
но разный возвращаемый тип или/и разный список аргументов. 
Определите в объекте Group две функции с одинаковым име-
нем, например: double Age(); и double Age(int limit);. Первая 
функция пусть возвращает средний возраст группы людей, а 
вторая функция пусть возвращает средний возраст людей в 
группе, возраст которых не больше некоторого граничного зна-
чения limit. Функции отличаются списком аргументов. 

20.  Проверьте работу перегруженных функций, отобразив 
на экране подсчитанные два значения среднего возраста. 

21.  Перегрузите оператор индексирования. Если раньше, 
чтобы обратиться к элементу массива, нам необходимо было 
вызывать функцию GetPerson, то, определив оператор индекси-
рования, мы будем использовать только квадратные скобки. 
Сравните две строки кода: 

 
Person man = group.GetPerson(2); 
Person man = group[2]; 
 
В объекте Group с помощью ключевого слова operator оп-

ределите оператор индексирования, например:  
 
Person& Group::operator[](int i).  
 
В теле оператора напишите код, возвращающий i-тый эле-

мент массива, т.е. объект Person. 
22.  Выведите на экран с помощью оператора индексирова-

ния любой один элемент массива group, например третий.  
23.  Перегрузите бинарный оператор, например оператор 

сложения (+), для объекта Person. Пусть оператор сложения 
будет возвращать суммарный возраст двух человек. Опишите в 
объекте Person данный оператор как дружественную функцию с 
помощью ключевого слова friend, например: 

   
   friend double operator+(Person& p1, Person& p2); 
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Эта строка кода означает, что оператор сложения не при-
надлежит объекту, но ему доступны все закрытые данные и ме-
тоды объекта. 

В файле person.cpp определите оператор сложения, напри-
мер: 

 
double operator + (Person& p1, Person& p2) 
                { return (p1.Age + p2.Age); } 
 
Здесь мы напрямую обращаемся к закрытому полю Age 

объекта Person. 
24.  Проверьте работу оператора с помощью следующих 

строк кода: 
double sum = group[1] + group[3]; 
cout << sum << endl; 
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5 ПРАВИЛА ОФОРМЛЕНИЯ ЛАБОРАТОРНЫХ 
РАБОТ 

 
А) Лабораторная работа состоит в выполнении задания 

(глава 4), описании материала в формате MS WORD и подго-
товке файлов проекта (файлы *.ехе, *.cpp, *.h) Задание может 
быть выполнено в любой среде программирования С++ (VC++ 
или встроенного компилятора электронного учебника), но с 
обязательным ее указанием в файле отчета (дело в том, что су-
ществуют некоторые отличия программирования в средах, на-
пример Visual Studio и Borland). 

 
Б) Лабораторная работа обязательно должна содержать: 
– краткое изложение теоретического материала по каждому 

из рассматриваемых разделов; 
– комментарии по тексту программы, описывающие основ-

ные особенности объектно-ориентированного программирова-
ния на С++; 

– объектно-ориентированные дополнения (создание нового 
класса, применение явного наследования и др.) и изменения, 
приводящие к усложнению варианта лабораторных работ. 

 
В) Окончательно сформированное задание содержит файл 

описания word и файлы проекта *.ехе, *.cpp, *.h. 
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